您好,欢迎访问代理记账网站
  • 价格透明
  • 信息保密
  • 进度掌控
  • 售后无忧

Unity2020打包APK出现Gradle系列问题处理方法

最近项目版本升级Unity2019.2.5 -> Unity2020.3,遇到了不少坑,在这里记录一下解决方案。

目录

  • 一、Unity安装时遇到的报错
  • 二、导入AAR打包报错(Gradle系列报错)
    • 1、报错 Gradle Error: Colliding Attributes
      • (1)清单文件AndroidManifest.xml设置有误
      • (2)清单文件 LauncherManifest.xml与AndroidManifest.xml合并失败
    • 2、报错 Gradle Error: MinSDK in Manifest
    • 3、报错Could not resolve all artifacts for configuration ‘:classpath’.
    • 4、报错Could not delete old ...Temp\lgradleOut\launcher \buildy\reports \lintresults-release-fatal.html
    • 5、报错 Minimum supported Gradle version is 5.4.1. Current version is 5.1.1
    • 6、其他问题

一、Unity安装时遇到的报错

Unity 2020安装失败、项目加载报错、JDK 、JRE 、SDK、 NDK下载及配置 等问题参考这篇博客:
https://blog.csdn.net/qq_43505432/article/details/117226308

二、导入AAR打包报错(Gradle系列报错)

1、报错 Gradle Error: Colliding Attributes

在这里插入图片描述在这里插入图片描述

打开详情提示四个报错,经过分析和实验,可能有以下几个综合原因导致

(1)清单文件AndroidManifest.xml设置有误

Unity2020对于之前版本有了不少变化,如下图,加了各种自定义的清单文件。
如果不桥接安卓工程,可以不勾选Custom Launcher Manifest,这是启动APP的清单文件。
在这之前,普及一下清单文件的合并概念:
Unity发布Android的APK时,关于AndroidManifest的合并,主AndroidManifest文件为Plugins/Android目录下的AndroidManifest文件,如果不自定义,Unity会根据系统模板默认加一个,AndroidManifest文件分为两种情况:
1、当存在多个jar包时,需要手动合并每个jar包的AndroidManifest到主AndroidManifest文件。
2、当存在aar包时,在导出APK时,Unity会解析aar包的资源,并自动把它们的AndroidManifest文件合并主AndroidManifest文件。
在这里插入图片描述
接下来,把安卓端提供的 aar 放到项目的\Assets\Plugins\Android目录下,在这里插入图片描述
用360压缩工具打开aar,把AndroidManifest.xml文件拖出来,
在这里插入图片描述
用文本工具打开(如:sublime Text),修改包名和unity里面的一样
在这里插入图片描述在这里插入图片描述

在application中添加tools:replace=“android:icon, android:theme”,指定Icon,防止unity与安卓冲突
在这里插入图片描述

(2)清单文件 LauncherManifest.xml与AndroidManifest.xml合并失败

接着修改LauncherManifest.xml。
在这里插入图片描述

勾选Custom Launcher Manifest,会发现项目的\Assets\Plugins\Android目录下多出了LauncherManifest.xml文件,这是引擎提供的模板,需要手动修改一下,上面的报错主要问题就是因为没有修改模板,直接用默认设置导致的。

根据报错我们可以看到系统提示的冲突文件地址是在Temp缓存文件中,而这个缓存文件的模板就是\Assets\Plugins\Android目录下的LauncherManifest.xml,如果我们没勾选上面的Custom Launcher Manifest选项,这个缓存文件的模板就是引擎默认模板,在此安装路径下D:\Unity\2020.3.0f1c1\Editor\Data\PlaybackEngines\AndroidPlayer\Apk。

在这里插入图片描述
在这里插入图片描述
打开一看,果然找到了报错里的提示信息
在这里插入图片描述

至此,我们终于理清楚关系了,因为系统模板是默认值,所以系统提供的自定义清单文件也是默认值,所以打包时缓存文件中的icon也是默认值,这就和 主清单文件AndroidManifest中的icon起了冲突。

那问题就简单了,把\Assets\Plugins\Android目录下的LauncherManifest.xml文件中的icon修改成主清单文件AndroidManifest中的icon。
另外,报错详情中还有个Suggest,提示我们加入这个tools:replace=“android:icon”,这应该是用于合并icon的,一并加到清单文件中,最后如下图,包名和icon名改成和主清单文件中一样:
在这里插入图片描述
到这里可以试着打包以下,如果还报Gradle相关的错,可能是Gradle版本问题,参照第四个问题。

2、报错 Gradle Error: MinSDK in Manifest

在这里插入图片描述
这是由于安卓端导出aar时,设置了sdk最低版本,而Unity设置的最低sdk版本比安卓要求的最低版本要低。
在这里插入图片描述
解决办法:直接删除清单文件中的minSdkVersion,取消最低版本设置要求,同时unity的MiniMumAPI Level选项设置到此APL level。
在这里插入图片描述

3、报错Could not resolve all artifacts for configuration ‘:classpath’.

可能是Gradle版本问题,Unity每个版本都对应指定的Gradle及其工具的版本。
Gradle的安装路径,默认是在C:\Users\XXX\ .gradle\wrapper\dists路径里面:
在这里插入图片描述

若C盘里没有.gradle文件夹,即unity打包时没有生成,一般Unity第一次打包会自动下载指定版本放到此位置。如果有,可能版本不对,剪切到其他文件夹备份一下,然后让unity重新下载一次。

Gradle的配置文件在引擎安装路径D:\Unity\2020.3.0f1c1\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\GradleTemplates下,如果下载很慢,可以在里面修改下载路径成国内镜像地址。
在这里插入图片描述
网上很多自己搜 “unity配置gradle”,如:https://www.jianshu.com/p/0562b768fdff
Gradle插件版本必须和Gradle版本对应起来,可查看Gradle官方的对应关系。
在这里插入图片描述

4、报错Could not delete old …Temp\lgradleOut\launcher \buildy\reports \lintresults-release-fatal.html

参考第四条错误处理方法
在这里插入图片描述

5、报错 Minimum supported Gradle version is 5.4.1. Current version is 5.1.1

参考第四条错误,更换Gradle所使用的版本,必须等于或大于5.4.1。
https://blog.csdn.net/qq_33795300/article/details/112787575

6、其他问题

(1)failed processing manifest.
解决方案:在gradle.properties添加代码:
android.enableAapt2=true

(2)Execution failed for task ‘:app:mergeDebugResources’.
A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
Android resource compilation failed
解决方案:在gradle.properties添加代码:
android.enableJetifier = true
android.useAndroidX = true

(3)Error:Execution failed for task ‘:app:mergeDebugResources’.
There were multiple failures while executing work items
A failure occurred while executing com.android.build.gradle.tasks.MergeResources$FileGenerationWorkAction
解决方案:在build.gradle的defaultConfig中添加代码:
vectorDrawables.useSupportLibrary = true

(4)Failed to apply plugin [id ‘com.android.internal.version-check’]

解决方案:在gradle.properties添加代码:
android.overridePathCheck=true

(5)Error:Execution failed for task ‘:processReleaseGoogleServices’.

No matching client found for package name ‘com.zwwx.game.WinterJump’
错误原因:google-services.json中的包名与build.gradle中的包名不一致。
解决方案:包名改成一致就行了。


分享:

低价透明

统一报价,无隐形消费

金牌服务

一对一专属顾问7*24小时金牌服务

信息保密

个人信息安全有保障

售后无忧

服务出问题客服经理全程跟进