您好,欢迎访问代理记账网站
  • 价格透明
  • 信息保密
  • 进度掌控
  • 售后无忧

tensorflow+pytorch安装

想配置一个tensorflow+pytorch的环境,辛辛苦苦把tf配置好了结果pytorch又用不了了,真是按下葫芦起了瓢。
安装版本如下:

  • tensorflow-gpu 2.4.1
  • pytorch 1.7.1
  • torchvision 0.8.2
  • torchaudio 0.7.2
  • cudatoolkit 10.1
  • cudnn 7.6.5

Tensorflow

我用的是conda进行安装,貌似pip安装tensorflow的时候要自己下载各种依赖还有cudatoolkit,用conda相对来说一劳永逸一点。

conda install tensorflow-gpu

现在的tensorflow已经不区分cpu版和gpu版了,理论上来说conda install tensorflow也可以,但是貌似这样不会帮你安装cudatoolkit,所以还是老老实实加上-gpu的后缀吧。
这行命令会帮你安装好tensorflow、cudatoolkit、cudnn
验证一下:

import tensorflow as tf
import os
os.environ['CUDA_VISIBLE_DEVICES']='0'
print(tf.test.is_gpu_available())

结果是True,证明TF已经安装好了

Pytorch

pytorch版本最好是要和上面安装的cudatoolkit对应,我安装的是cudatoolkit10.1,在pytorch官网可以找到对应的版本为pytorch=1.7.1 torchvision=0.8.2 torchaudio=0.7.2
同样的用conda进行安装,不过这里由于已经安装好了cudatoolkit了,因此不需要再次下载cudatoolkit

conda install pytorch=1.7.1 torchvision=0.8.2 torchaudio=0.7.2 -c pytorch

其中’-c pytorch’指定的是下载的源,我这里pytorch的源指定的是北外的镜像 https://mirrors.bfsu.edu.cn/anaconda/cloud 下载起来也很快。镜像源的设置具体可以看我另一篇关于北外镜像源的博客:

其他问题

我发现pip下载的pytorch并不会安装cudatoolkit,而是把cuda集成在了pytorch的包中(?)
这是另一个虚拟环境中用pip安装的pytorch版本在这里插入图片描述
不知道这样是不是可以避免和环境中的cudatoolkit的版本的冲突呢,欢迎大佬解答


分享:

低价透明

统一报价,无隐形消费

金牌服务

一对一专属顾问7*24小时金牌服务

信息保密

个人信息安全有保障

售后无忧

服务出问题客服经理全程跟进